Intermittent Issues Loading Tamr UI & APIs

Incident Report for Tamr

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:46 UTC

Monitoring

Cloudflare has implemented a fix, and our teams are monitoring to ensure full recovery.
Posted Nov 18, 2025 - 14:43 UTC

Identified

Our CDN provider Cloudflare is currently experiencing networking issues (https://www.cloudflarestatus.com/incidents/8gmgl950y3h7), which is impacting users' ability to load and use the Tamr web interface.
Posted Nov 18, 2025 - 12:03 UTC
This incident affected: Tamr Cloud - US (Web Portal), Tamr Cloud - EU (Web Portal), Tamr Cloud - UK (Web Portal), Tamr Cloud - CA (Web Portal), and Tamr Cloud - AP (Web Portal).