Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 03, 2025 - 13:00 UTC
Scheduled
mproved Clarity and Control for Cluster Verification
We are pleased to announce an upcoming improvement to make it easier to understand which records are verified in a cluster and to have more control over verifying records when moving records between clusters.
Previously, when curators performed clustering overrides, source records moved to new clusters were verified in the new cluster, and a verified badge appeared for these records. Other records in that cluster were implicitly verified in the cluster; there was no UI indication that these records were verified, but these implicit verifications ensured that the records in the cluster did not recluster with the removed records on subsequent runs.
What's New?
One-time Update: A one-time update will add verification badges to all records that were previously implicitly verified, making them clearly visible in the UI.
More Control over Verifications: New UI options let you decide whether to verify all records in a destination cluster when moving records, and the same for the original cluster. Similar options are available when creating new entities from source records. It is recommended that you verify all involved records. A verification ensures that the cluster id for that record will not change but any unverified record can cluster freely, including "rejoining" a record that it was previously split from if it is not also verified.
About the Automatic Update
Through a one-time update, Tamr will add verification badges to all records that have been implicitly verified in a cluster based on the last data product run. This way, all verified records will be clearly labeled in the UI.
The activity log will also show the records to which verified badges were added, with System as the user performing the verification.
The one-time update will run in the background, and may take up to three hours. Users can continue to view data in Tamr Cloud UI. However, during the update users will not be able to perform curation activities or run data products. Publish jobs can be run at this time.
Rest assured, this update will not change your current clustering results or Tamr IDs. It’s simply providing more insight in which records are verified in a cluster.
Posted May 21, 2025 - 14:23 UTC
This scheduled maintenance affected: Tamr Cloud - US (Web Portal, Data Pipelines).